Как при обмене Excel/csv выгрузить свое поле из файла в строку документа Mobile SMARTS и загрузить это поле обратно

Последние изменения: 16.11.2022

Обмен документами в системе Mobile SMARTS осуществляется с помощью утилиты «Excel Csv обмен», которая входит в пакет установки (см. также Расположение файлов и их назначение).

Как подготовить документы для обмена Excel/CSV файлами

Вариант 1. Подготовить документы и загружать/выгружать не меняя «коробочных решений». Данное решение предполагает заполнение в документах только актуальные поля, не внося изменения в неиспользуемые. Документы содержат множество полей, некоторые из них возможно не будут использоваться при работе.

Вариант 2. Через удаление ненужных полей в (за)выгружаемом документе. Второй вариант предполагает изменение шаблонов документов, используемых платформой Mobile SMARTS. В данном случае возможно получить формы документов, удобные вам — убрать неиспользуемые колонки, поменять их местами, подстроить шаблоны файлов под учетную систему.

Вариант 3. Через изменения конфигурации Mobile SMARTS, этот способ позволяет внести необходимые изменения в конфигурацию, добавить поля, задать их обработку, изменение или вывод по вашим требованиям, используя как готовые процедуры так и создавая полностью свои нетиповые бизнес-процессы. Также можно установить пустую базу для создания всех процедур и алгоритмов с чистого листа, используя например добавление поля в номенклатуру.

При установке многих продуктов, с обменом через Excel/Csv, копируются «Демо-файлы», во всех форматах (xls, xlsx, csv). В данной статье будем использовать файлы *.xlsx. Получить доступ к папке можно используя входящую в состав платформы Mobile SMARTS утилиту «Excel/Csv обмен».

Запуск утилиты Excel/CSV обмена для ОС Windows

Для запуска утилиты нажмите в нижнем левом углу рабочего стола на кнопку «Пуск», откройте главное пользовательское меню операционной системы Windows.

Выберите папку «Cleverence Soft», нажмите на «Утилита Excel и CSV обмена», далее выберите нужную базу данных приложения Mobile SMARTS (рассмотрим на примере «Магазин 15: Расширенный с Кировкой»), нажмите кнопку «Выбрать».


Откроется окно утилиты. Для отправки документов на терминал нажмите кнопку «На сервер», для того чтобы забрать файлы с терминала нажмите на кнопку «С сервера» (при работе базы в режиме прямого подключения к устройству (без сервера) кнопки будут иметь вид «На терминал», «С терминала»).


Утилита Excel/Csv

Для обмена документами с ТСД запустите на рабочем столе менеджер баз Mobile SMARTS,


далее выберите нужную базу из списка, например «Склад 15», справа от кнопки «Открыть» нажмите на раскрывающийся список, запустите «ExcelCsv обмен», запускается утилита.


Обратите внимание. В меню «Файл->Параметры обмена» нужно выбрать формат обмена xls/xlsx/csv, здесь также можно настроить пути к папкам обмена.

Для этого зайдите в меню «Файл», выберите окно «Параметры обмена», настройте используемый формат данных и переопределите пути к папкам «На терминал» и «С терминала». В пункте «Формат файлов» поставьте галочку на нужном параметре.


Для загрузки документа в базу данных Mobile SMARTS и далее в ТСД файл «Приход» необходимо поместить в папку «На терминал»: «C:\ProgramData\Cleverence\Базы Mobile SMARTS\Имя Базы\XlsCsv\На терминал»

Попасть в эту папку можно непосредственно из утилиты выбрав пункт меню «Папки->На терминал». В этой папке находятся все документы предназначенные к загрузке в систему и на ТСД.

После нажатия кнопки «На сервер» утилита проверяет файл на возможные ошибки и в случае успеха отправляет на сервер, далее документ доступен на ТСД.

Файл из папки «На терминал» переносится в папку «Архив», файл номенклатуры и файлы таблиц остаются в текущей папке.

Выгрузка документов из Mobile SMARTS как и модификация шаблонов практически не отличается от загрузки.

Шаблон выгрузки «Документ» находится по пути «C:\ProgramData\Cleverence\Базы Mobile SMARTS\Имя Базы\XlsCsv\Templates\Download»

Запуск утилиты Excel/CSV обмена через конфигуратор

Выберите нужную базу данных из списка, с которой будет работать утилита обмена, затем справа от кнопки «Открыть» нажмите на раскрывающийся список, выберите «Открыть ExcelCsv обмен».




Нажмите в меню утилиты на кнопку «Папки», далее выберите соответствующий вариант загрузки: «На мобильное устройство» или «С мобильного устройства».

В выбранной базе автоматически создается папка «XlsCsv» с подпапками «На терминал» и «С терминала» (согласно способам загрузки «На мобильное устройство» и «С мобильного устройства»).


После нажатия кнопки «На сервер» (где документы выгружаются/передаются в базу данных Mobile SMARTS, на ТСД документы загружаются при обмене сервера с терминалом) большая часть загружается в систему в папку «Архив» с добавлением даты и времени документа.

В текущей папке остаются файлы справочника номенклатуры и файлы таблиц, а также файлы документов, которые были пропущены из-за настроек выгрузки (например, настроен обмен в формате .xlsx, а загружаемые файлы в формате .csv) и файлы документов, которые не были выгружены из-за системных ошибок.

Откройте файл «Номенклатура.xlsx», первое, что бросается в глаза — поля заполненных числами типа

«253a91e0-269e-4ff1-bb36-b33e878c69ab».

Это GUID (Globally Unique Identifier), который формируется в учетной системе или генерируется производителем.

Добавьте свою строку с товаром. Заполните только те поля, которые известны. Пример «Лапти****»


При заполнении важно заполнить поля «А» и «Н» (ProductId и PackingId), значение может быть любым, сформировано вручную или вашей учетной системой.

Далее сохраните файл и закройте программу в которой он был создан. Откройте утилиту обмена и нажмите кнопку «На сервер», утилита проверяет правильность файла и в случае успеха, загружает его в платформу Mobile SMARTS.

Проверить загрузилось или нет можно в панели управления платформой вкладка «Данные-Номенклатура», либо запустив «Клиент для ПК» выбрав меню «Просмотр справочников».


Обратите внимание. Несмотря на то, что в файле «Номенклатура» более 150 строк, приложение сообщает, что товаров 79. Это происходит из-за того, что один и тот же товар идет в разной упаковке, например молоко 5 пакетов и одна коробка с 6-ю пакетами. Строк в номенклатуре 2, а позиция одна.

Нажмите на кнопку «Товары» — появляется список товаров. Поиск можно осуществить по «Артикулу», «Наименованию», «Штрихкоду», обратите внимание, что вводить необходимо не менее 3-х символов. В случае совпадения поискового запроса на экран выводятся все позиции имеющие совпадение, далее можете выбрать необходимую.

Рассмотрим на примере базы данных «Склад 15: Расширенный с Кировкой» операцию «Оприходование товара на складе».

Для этого учетная система должна сформировать файл «Приход на склад *******», здесь вместо ***** — впишите текст, номер накладной, поставщика или все вместе.

Можно создать его самостоятельно на основе демонстрационного файла «Приход на склад демо» согласно полного пути к папке: «C:\ProgramData\Cleverence\Базы Mobile SMARTS\Имя Вашей базы\XlsCsv\На терминал\Демо данные\xlsx»

Откройте его и сохраните в папку: «C:\ProgramData\Cleverence\Базы Mobile SMARTS\Имя Вашей базы\XlsCsv\На терминал»

Имя файла в папке на загрузку («На терминал») должно соответствовать желаемой операции. В данном случае «Приход на склад». Заполните демо-файл данными и удалим все строки с демо-данными.

Здесь следует обратить внимание на изменение ячейки «B2». Ячейка обязательно должна содержать «Приход на склад №», после символа № может быть текст, который будет отображен в названии документа на терминале сбора данных. В данном случае «Лапти 2021». Ячейки ниже заполняются в соответствии с используемыми вами операциями или бизнес-процессами.

Загрузка файла в систему производиться как и в предыдущем случае нажатием на кнопку «На терминал» (при работе базы в режиме прямого подключения к устройству (без сервера)).

Обратите внимание. Если база данных Mobile SMARTS работает в режиме «Подключение к серверу» (см. Настройка базы данных Mobile SMARTS), то загрузка файла производится путем нажатия кнопки «На сервер».

Утилита «ExcelCsv обмен» проверяет файлы и отправляет на сервер и терминал соответственно, после этого на ТСД или на десктопном приложении, загрузится документ.

Нажмите «Приход на склад», далее «Приход Лапти 2021» и можете приступить к сканированию. Здесь можно использовать только штрихкоды, которые ввели в систему при добавлении нового товара в «Номенклатуру», где

11111110, 11111111 — это код товара,

01011, 01012- это штрихкод.

Поиск в Mobile SMARTS может производится по любому из этих кодов.


Вставить номер штрихкода в окно сканирования можно комбинацией клавиш Ctrl+V. После сканирования, на складе пересчитывайте товар и введите количество на терминале (либо можно сканировать все позиции по одной). Далее нажмите «Esc» два раза и выберите «Завершить документ».

После этого документ с фактически подсчитанным количеством товара попадает на сервер и далее его можно выгрузить обратно, утилитой обмена, нажав кнопку «С терминала» или «С сервера» (см.выше).

В результате в папке «С терминала»

«C:\ProgramData\Cleverence\Базы Mobile SMARTS\Имя базы\XlsCsv\С терминала»

появляется файл «Приход на склад № Лапти 2021». Из этого файла можно увидеть, что фактически принятое количество соответствует заявленному, номер терминала и оператора, если эта функция включена в опциях. Так же в этом файле, выгрузились все поля используемые системой.

Далее можете обработать этот документ вручную или настроить его обработку в учетной системе.

Удаление ненужных полей в (за)выгружаемом документе


Это вариант позволяет получить более простые документы, избавившись от неиспользуемых полей. Например файл для загрузки на ТСД/Сервер может выглядеть так



Файл после выгрузки выглядит так:

Также для загрузки в систему из приведенного на скриншоте документа можно удалить колонки «Штрихкод», «Наименование», «Цена» и «Факт» и оставить только «Код», «Упаковка» и «План». С учетом того что все эти данные уже есть в номенклатуре, то платформа обработает все корректно.


Для этого соответственно нужно также изменить файлы шаблонов на загрузку/выгрузку.

Измененный загружаемый шаблон: «C:\ProgramData\Cleverence\Базы Mobile SMARTS\Имя Базы\XlsCsv\Templates\Upload\Документ.xlsx»

Измененный выгружаемый шаблон: «C:\ProgramData\Cleverence\Базы Mobile SMARTS\Имя Базы\XlsCsv\Templates\Download\Документ.xlsx»



Обратите внимание. Можно использовать разные шаблоны для разных типов документов. Для этого файл шаблона должен называться по имени типа документа. Например, «ПеремещениеПоСкладам.xlsx». Если для какого-либо типа документов не найден соответствующий ему шаблон, используется общий шаблон «Документ.xlsx».

Перед изменением шаблонов, определитесь, какие поля будут использоваться и какие могут понадобиться в будущем, чтобы не пришлось переделывать несколько раз.

Обратите внимание. Помимо удаления неактуальных полей, в платформу Mobile SMARTS можно добавить и новые, полностью уникальные поля и идентификаторы. Добавить можно простое «информационное» или сложное «вычисляемое поле».

С более полной информацией о полях можно ознакомится в статье «Дополнительные поля». Поля могут быть созданы и отображены в системе, из любых исходных полей или данных. Например, может быть создано поле, которое в определенном формате отображает сведения о товаре собранные из трех разных исходных полей.

Как добавить дополнительное поле в строку документа

Иногда возникает необходимость добавить дополнительное поле в строку документа. Например с товаром идет подарок или нигде не указанные дополнительные характеристики товара.

Как добавить дополнительное поле в строку документа можно прочитать в статье «Добавление дополнительного поля в строки документа Mobile SMARTS на примере файла Excel/CSV».

Была ли статья полезна?
Спасибо за ваш отзыв!
Отзыв
Заполните, пожалуйста, данную форму, что конкретно вы не нашли, оставьте свои комментарии о работе сайта / полезности / сложности с навигацией
0/500